This project has moved and is read-only. For the latest updates, please go here.

Error on Mono

Topics: bug report (break and fix)
Jun 25, 2008 at 10:46 AM
Hi lextm, I'm very grateful for your work.
I have a question to do.
I've created a simple console application that is listening for traps. I've compiled it under Windows and it works great. Now i need to make it work under a Linux distro but when i run it through mono, i get this error:

** (Trap.exe:2345): WARNING **: Missing method System.Net.Sockets.Socket::get_ReceiveBufferSize() in assembly /usr/lib/mono/gac/System/, referenced in assembly /usr/src/test/SharpSnmpLib.dll

I've tried upgrading mono version to 1.9.1 but it seems not to work at all. Do you know if there is something I can do (even magic rituals :P ) to fix this problem?

Thanks a lot.
Jun 25, 2008 at 1:10 PM
Hi, it is weird to me too :-( Although I claim #SNMP supports Mono, I only tested it against MoMA. It seemed like the Mono version you used did not have System.Net.Sockets.Socket::get_ReceiveBufferSize() implemented so may you fire a bug report to the Mono guys? If possible, you may check out latest Mono from their SVN repository to see if this method is added now.

I am right now checking #SNMP source code to see if there could be a workaround. I posted findings here if I were lucky :-)
Jun 25, 2008 at 2:58 PM
Thanks for the reply :)
I'm trying to download and install a new linux distro (previous one run on a virtual server machine) in order to properly install latest mono version.
If it will keep reporting that error I'll report the bug to Mono guys :)
Jun 26, 2008 at 3:10 PM
Problem solved :)

I've installed mono 1.9 on a brand new Ubuntu server 8.04. Now the program works well on both Windows and Linux.
Thanks for the support ;)
Marked as answer by lextm on 10/6/2013 at 9:38 PM
Jun 27, 2008 at 9:33 AM
Hi. Thanks for testing #SNMP on Linux. Glad it works at last.